HCNA——IP路由原理、静态路由基本配置

HCNA——IP路由原理、静态路由基本配置

在互联网中进行路由选择所使用的设备,或者说,实现路由的设备,我们称之为路由器。

路由器关键功能

  • 检查数据包的目的地
  • 确定信息源
  • 发现可能的路由
  • 选择最佳路由
  • 验证和维护路由信息

什么是路由?

路由是指导IP报文发送的路径信息
enter description here

路由表

路由器工作时依赖于路由表进行数据的转发。路由表犹如一张地图,它包含着去往各个目的的路径信息(路由条目)。每条信息至少应该包括下面3个内容:

  • 目的网络——表明路由器可以到达的网络的地址,可理解为去哪里。
  • 下一跳——通常情况下,下一跳(next hop)一般指向去往目的网络的下一个路由器的接口地址,该路由器称之为下一跳路由器。
  • 出接口——表明数据包从本路由器的哪个接口发送出去。

IP路由过程

enter description here

  • PS:静态路由配置需双向配置路由表 否则接收不到返回数据包 链路不通

路由的来源—链路层发现的路由

enter description here
链路层发现的路由称之为直连路由

PS:各设备三层接口接起来就会自动发现路由

路由的来源—静态路由

enter description here
管理员手工添加的路由 称之为静态路由

路由的来源—动态路由

enter description here
上图是通过路由协议来学习到路由表 RIP OSPF协议

静态和动态路由 优缺点

enter description here

静态路由是由管理员手工配置而生成的路由。
其优点为:

  • 使用简单,容易实现
  • 可精确控制路由走向,对网络进行最优化调整
  • 对设备性能要求较低,不额外占用链路带宽

其缺点为:

  • 网络是否通畅以及是否优化,完全取决于管理员的配置
  • 网络规模扩大时,由于路由表项的增多,将增加配置的繁杂度以及管理员的工作量
  • 网络拓扑发生变更时,不能自动适应,需要管理员参与修正

静态路由在实际应用中相当广泛,通常应用于以下两个场景:

  • 小规模、稳定的网络。
  • 路径选择的控制,即控制某些目的网络的路由走向。

静态路由通信实验

  1. 实验需求:路由器各接口及主机的IP地址和掩码。要求采用静态路由,使图中任意二台主机之间都能互通。

  2. 实验拓扑:
    enter description here

  3. 实验配置思路

  • 先给4台路由器添加 端口-同异步WAN 接口卡(2SA) 添加时先停止设备。
  • 配置各路由器各接口的IPv4地址,使网络互通。
  • 在路由器上配置到目的地址的IPv4静态路由。
  • 在各主机上配置IPv4网关,使任意两台主机可以互通。

配置参数表

PC1 ip 192.168.23.100/24 gateway 192.168.23.2
PC2 ip 192.168.1.100/24 gateway 192.168.1.1
PC3 ip 192.168.4.100/24 gateway 192.168.4.4

四台路由器根据拓扑图给出的接口对应Ip配置 命令参考如下

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
<Huawei>system-view 
Enter system view, return user view with Ctrl+Z.
[Huawei]sysname R1
[R1]interface GigabitEthernet 0/0/0
[R1-GigabitEthernet0/0/0]ip address 192.168.1.1 24
Jun 7 2018 10:39:58-08:00 R1 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP
on the interface GigabitEthernet0/0/0 has entered the UP state.
[R1-GigabitEthernet0/0/0]quit
[R1]interface Serial 1/0/0
[R1-Serial1/0/0]ip address 192.168.12.1 24
[R1-Serial1/0/0]quit
[R1]display ip interface brief
*down: administratively down
^down: standby
(l): loopback
(s): spoofing
The number of interface that is UP in Physical is 3
The number of interface that is DOWN in Physical is 2
The number of interface that is UP in Protocol is 3
The number of interface that is DOWN in Protocol is 2

Interface IP Address/Mask Physical Protocol
GigabitEthernet0/0/0 192.168.1.1/24 up up
GigabitEthernet0/0/1 unassigned down down
NULL0 unassigned up up(s)
Serial1/0/0 192.168.12.1/24 up up
Serial1/0/1 unassigned down down
[R1]

PC2 ping通 PC3

  • 在四台路由器上配置路由表

R1

1
[R1]ip route-static 192.168.4.0 24 s1/0/0 192.168.12.2

R2

1
[R2]ip route-static 192.168.4.0 24 g0/0/0 192.168.23.3

R3

1
[R3]ip route-static 192.168.4.0 24 s1/0/0 192.168.34.4

为什么R4不用配置路由表呢?

R4与192.168.4.0/24 学习到直连路由

下面我们来用PC2 ping PC3
enter description here

为什么ping不通呢?

PS:前面讲到配置静态路由需要双向配置 否则在返回数据包时没有匹配到路由表 因此接收不到

进行上面的操作对路由器配置反向路由表

R4

1
[R4]ip route-static 192.168.1.0 24 s1/0/0 192.168.34.3

R3

1
[R3]ip route-static 192.168.1.0 24 g0/0/0 192.168.23.2

R2

1
[R2]ip route-static 192.168.1.0 24 s1/0/0 192.168.12.1

配置完成后进行ping
enter description here
PC2与PC3成功互通!!!
PS:路由表只关心是否能到达下一跳 至于数据包所要到达的地址是否能到达 是下一跳路由器的工作

PC1、PC2、PC3 互通

目前我们只PC2与PC3互通,要怎么实现PC1 ping通 PC2 PC3呢?

与上述操作同理 我们的路由器中没有PC1网络的路由表 所以我们还得再路由器上添加PC1网络的双向路由表

R1

1
[R1]ip route-static 192.168.23.0 24 s1/0/0 192.168.12.2

R4

1
[R4]ip route-static 192.168.23.0 24 s1/0/0 192.168.34.3

PC1 PC2 PC3 成功互通!!!
enter description here

3台PC互通 那么我能与路由器互通吗?

PS:与上述同理 在路由表找不到对方路由器网络 路由表时是不通的 比如此时R1 ping R4 是不通的 对路由器添加对方网络的双向路由表即可

实验总结

本节内容学习到IP路由原理、静态路由基本配置 以及数据的收发包走向是根据路由表来进行转发 还有路由表只关心能否到达下一跳 就如接力比赛 交接棒后一切事与我无关 是下一个工作者的事

与你分享网络技术文章,你的支持让我有更大的动力!